青果社区_青果网_青果论坛_无尽战区论坛  
  
展开

小喇叭     

全站
清唱。 说: 论坛开启邀请注册,邀请码可以关注公众号【青果趣味】发信息【邀请码】给公众号即可免费获取邀请码。
2017-09-14
全站
清唱。 说: 近期开启邀请码注册,请珍惜账号。
2017-08-29
查看: 378|回复: 3
收起左侧

[源码] 易语言D3D9透视加准心源码 纯源码版无模块

[复制链接]
清唱。 (1)
发表于 2018-7-7 21:32:37 | 显示全部楼层 |阅读模式

这是一个创建于2018-7-7 21:32的主题,如果是[辅助类]帖可能已经失效建议不要下载(标注了永久性或者脚本类工具除外),其他类贴其中的信息可能已经有所发展或是发生改变,请自行甄别。

马上注册,拥有社区全部功能,享用更多特权,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册账号

x
部分代码:


[AppleScript] 纯文本查看 复制代码
.版本 2

D3DVTable = WOD_读整数 (D3D9VTable (GetModuleHandleA_ASM (“d3d9.dll”)))
Release = WOD_读整数 (汇编加法 (D3DVTable, 8))
SetRenderState = WOD_读整数 (汇编加法 (D3DVTable, 228))
GetRenderState = WOD_读整数 (汇编加法 (D3DVTable, 232))
GetStreamSource = WOD_读整数 (汇编加法 (D3DVTable, 404))
DrawIndexedPrimitive = WOD_读整数 (汇编加法 (D3DVTable, 328))
DrawIndexedPrimitive_call = Hook_EDI_EDI_NOP_5 (DrawIndexedPrimitive, _取子程序真实地址 (&MyDrawIndexedPrimitive_2))
计算 ()
返回 (0)

.子程序 计算, , , '在这里选择

初始化颜色 ()
画出准星 = 真
.如果真 (画出准星)
    准星 (游戏宽度 ÷ 2, 游戏高度 ÷ 2, 设置色彩.黄色)
.如果真结束


.子程序 D3D9VTable, 整数型
.参数 Base, 整数型
.局部变量 n, 整数型

.计次循环首 (1212416, n)
    .如果真 (汇编_读字节集 (Base + n, 1) = { 199 })
        .如果真 (汇编_读字节集 (Base + n + 1, 1) = { 6 })
            .如果真 (汇编_读字节集 (Base + n + 6, 1) = { 137 })
                .如果真 (汇编_读字节集 (Base + n + 7, 1) = { 134 })
                    .如果真 (汇编_读字节集 (Base + n + 12, 1) = { 137 })
                        .如果真 (汇编_读字节集 (Base + n + 13, 1) = { 134 })
                            返回 (Base + n + 2)
                        .如果真结束

                    .如果真结束

                .如果真结束

            .如果真结束

        .如果真结束

    .如果真结束

.计次循环尾 ()
返回 (0)


人物透视.e (22.42 KB, 下载次数: 1)
[发帖际遇]: 清唱。 乐于助人,奖励 2 点 经验值. 幸运榜 / 衰神榜

发帖求助前要善用社区搜索功能,那里可能会有你要找的答案,就像度娘一样;

请不要反复发帖问【荣耀】怎么获取,点击这里查看【积分策略】,或者【点击赚积分】or【分享得荣耀】and【每日签到

如何回报帮助你的果友,一个好办法就是给对方加【荣耀】或是【点评】来赞美Ta,加分不会扣除自己的积分,做一个热心且受人欢迎的人。

77796885 (32057)
发表于 2018-7-20 09:05:34 | 显示全部楼层

发帖求助前要善用社区搜索功能,那里可能会有你要找的答案,就像度娘一样;

请不要反复发帖问【荣耀】怎么获取,点击这里查看【积分策略】,或者【点击赚积分】or【分享得荣耀】and【每日签到

如何回报帮助你的果友,一个好办法就是给对方加【荣耀】或是【点评】来赞美Ta,加分不会扣除自己的积分,做一个热心且受人欢迎的人。

xiaohong147 (32084)
发表于 2018-7-26 20:39:42 | 显示全部楼层

发帖求助前要善用社区搜索功能,那里可能会有你要找的答案,就像度娘一样;

请不要反复发帖问【荣耀】怎么获取,点击这里查看【积分策略】,或者【点击赚积分】or【分享得荣耀】and【每日签到

如何回报帮助你的果友,一个好办法就是给对方加【荣耀】或是【点评】来赞美Ta,加分不会扣除自己的积分,做一个热心且受人欢迎的人。

qqak320 (32232)
发表于 2018-9-3 23:43:30 | 显示全部楼层

发帖求助前要善用社区搜索功能,那里可能会有你要找的答案,就像度娘一样;

请不要反复发帖问【荣耀】怎么获取,点击这里查看【积分策略】,或者【点击赚积分】or【分享得荣耀】and【每日签到

如何回报帮助你的果友,一个好办法就是给对方加【荣耀】或是【点评】来赞美Ta,加分不会扣除自己的积分,做一个热心且受人欢迎的人。

 懒得打字嘛,点击右侧快捷回复【左侧自定义内容】 
您需要登录后才可以回帖 登录 | 注册账号

本版积分规则

快速回复 返回顶部 返回列表