青果社区_青果网_青果论坛_无尽战区论坛  
  
展开

小喇叭     

全站
清唱。 说: 论坛开启邀请注册,邀请码可以关注公众号【青果趣味】发信息【邀请码】给公众号即可免费获取邀请码。
2017-09-14
全站
清唱。 说: 近期开启邀请码注册,请珍惜账号。
2017-08-29
查看: 663|回复: 1
收起左侧

[文字教学] 易语言纯源码取网络时间校对北京时间

[复制链接]
清唱。 (1)
发表于 2018-12-7 10:09:43 | 显示全部楼层 |阅读模式

这是一个创建于2018-12-7 10:09的主题,如果是[辅助类]帖可能已经失效建议不要下载(标注了永久性或者脚本类工具除外),其他类贴其中的信息可能已经有所发展或是发生改变,请自行甄别。

马上注册,拥有社区全部功能,享用更多特权,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册账号

x
利用腾讯的网站取源码然后做子文本替换,其他的类似百度啥的原理是一样的


[PHP] 纯文本查看 复制代码
.版本 2
.支持库 internet
.支持库 spec

.子程序 取网络时间, 日期时间型, 公开
.局部变量 返回文本, 文本型
.局部变量 时间, 日期时间型

返回文本 = 到文本 (HTTP读文件 ("http://cgi.im.qq.com/cgi-bin/cgi_svrtime”))
延迟 (300)
返回文本 = 子文本替换 (返回文本, “ ”, “”, , , 真)
返回文本 = 子文本替换 (返回文本, “-”, “”, , , 真)
返回文本 = 子文本替换 (返回文本, “:”, “”, , , 真)
时间 = 到时间 (到文本 (到长整数 (返回文本)))
返回 (时间)

发帖求助前要善用社区搜索功能,那里可能会有你要找的答案,就像度娘一样;

请不要反复发帖问【荣耀】怎么获取,点击这里查看【积分策略】,或者【点击赚积分】or【分享得荣耀】and【每日签到

如何回报帮助你的果友,一个好办法就是给对方加【荣耀】或是【点评】来赞美Ta,加分不会扣除自己的积分,做一个热心且受人欢迎的人。

z140075 (32416)
发表于 2019-3-15 19:42:45 | 显示全部楼层

发帖求助前要善用社区搜索功能,那里可能会有你要找的答案,就像度娘一样;

请不要反复发帖问【荣耀】怎么获取,点击这里查看【积分策略】,或者【点击赚积分】or【分享得荣耀】and【每日签到

如何回报帮助你的果友,一个好办法就是给对方加【荣耀】或是【点评】来赞美Ta,加分不会扣除自己的积分,做一个热心且受人欢迎的人。

 懒得打字嘛,点击右侧快捷回复【左侧自定义内容】 
您需要登录后才可以回帖 登录 | 注册账号

本版积分规则

快速回复 返回顶部 返回列表