青果社区_青果网_青果论坛_无尽战区论坛  
  
展开

小喇叭     

全站
清唱。 说: 论坛开启邀请注册,邀请码可以关注公众号【青果趣味】发信息【邀请码】给公众号即可免费获取邀请码。
2017-09-14
全站
清唱。 说: 近期开启邀请码注册,请珍惜账号。
2017-08-29
查看: 339|回复: 1
收起左侧

[源码] 易语言倒计时关机锁屏重启待机源码

[复制链接]
清唱。 (1)
发表于 2019-1-25 11:19:50 | 显示全部楼层 |阅读模式

这是一个创建于2019-1-25 11:19的主题,如果是[辅助类]帖可能已经失效建议不要下载(标注了永久性或者脚本类工具除外),其他类贴其中的信息可能已经有所发展或是发生改变,请自行甄别。

马上注册,拥有社区全部功能,享用更多特权,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册账号

x

易语言倒计时关机锁屏重启待机源码

易语言倒计时关机锁屏重启待机源码

易语言倒计时关机锁屏重启待机源码

易语言倒计时关机锁屏重启待机源码


   
    需要添加精艺模块    P.s 青果社区   



代码:
[AppleScript] 纯文本查看 复制代码
.版本 2
.支持库 spec
.支持库 shell

.程序集 窗口程序集_启动窗口
.程序集变量 短, 整数型

.子程序 _按钮2_被单击

标签2.标题 = 时间到文本 (增减时间 (取现行时间 (), 7, 到整数 (编辑框1.内容)), 3) + “后” + 组合框1.取项目文本 (组合框1.现行选中项)
线程_启动 (&子程序1, , )

.子程序 子程序1
.局部变量 a

.如果真 (组合框1.现行选中项 = 0)
    _启动窗口.标题 = “想取消操作关闭软件即可”
    短 = 到整数 (编辑框1.内容) × 60
    调试输出 (短)
    .计次循环首 (短, a)
        短 = 短 - 1
        延迟 (1000)
        标签1.标题 = 到文本 (短) + “秒后” + 组合框1.取项目文本 (组合框1.现行选中项)
    .计次循环尾 ()
    系统_切换用户 ()
.如果真结束

.如果真 (组合框1.现行选中项 = 1)
    _启动窗口.标题 = “想取消操作关闭软件即可”
    短 = 到整数 (编辑框1.内容) × 60
    调试输出 (短)
    .计次循环首 (短, a)
        短 = 短 - 1
        延迟 (1000)
        标签1.标题 = 到文本 (短) + “秒后” + 组合框1.取项目文本 (组合框1.现行选中项)
    .计次循环尾 ()
    系统_关机 ()
.如果真结束

.如果真 (组合框1.现行选中项 = 2)
    _启动窗口.标题 = “想取消操作关闭软件即可”

    短 = 到整数 (编辑框1.内容) × 60
    调试输出 (短)
    .计次循环首 (短, a)
        短 = 短 - 1
        延迟 (1000)
        标签1.标题 = 到文本 (短) + “秒后” + 组合框1.取项目文本 (组合框1.现行选中项)
    .计次循环尾 ()
    系统_重启 ()
.如果真结束

.如果真 (组合框1.现行选中项 = 3)
    ' _启动窗口.禁止 = 真
    _启动窗口.标题 = “想取消操作关闭软件即可”

    短 = 到整数 (编辑框1.内容) × 60
    调试输出 (短)
    .计次循环首 (短, a)
        短 = 短 - 1
        延迟 (1000)
        标签1.标题 = 到文本 (短) + “秒后” + 组合框1.取项目文本 (组合框1.现行选中项)
    .计次循环尾 ()
    关闭系统 (4, )
.如果真结束

.如果真 (组合框1.现行选中项 = 4)
    ' _启动窗口.禁止 = 真
    _启动窗口.标题 = “想取消操作关闭软件即可”

    短 = 到整数 (编辑框1.内容) × 60
    调试输出 (短)
    .计次循环首 (短, a)
        短 = 短 - 1
        延迟 (1000)
        标签1.标题 = 到文本 (短) + “秒后” + 组合框1.取项目文本 (组合框1.现行选中项)
    .计次循环尾 ()
    关闭系统 (3, )
.如果真结束


.子程序 __启动窗口_将被销毁

结束 ()


.子程序 __启动窗口_创建完毕




懒人源码下载:
倒计时锁屏关机.zip (210.03 KB, 下载次数: 0)

发帖求助前要善用社区搜索功能,那里可能会有你要找的答案,就像度娘一样;

请不要反复发帖问【荣耀】怎么获取,点击这里查看【积分策略】,或者【点击赚积分】or【分享得荣耀】and【每日签到

如何回报帮助你的果友,一个好办法就是给对方加【荣耀】或是【点评】来赞美Ta,加分不会扣除自己的积分,做一个热心且受人欢迎的人。

z140075 (32416)
发表于 2019-3-15 19:41:41 | 显示全部楼层

发帖求助前要善用社区搜索功能,那里可能会有你要找的答案,就像度娘一样;

请不要反复发帖问【荣耀】怎么获取,点击这里查看【积分策略】,或者【点击赚积分】or【分享得荣耀】and【每日签到

如何回报帮助你的果友,一个好办法就是给对方加【荣耀】或是【点评】来赞美Ta,加分不会扣除自己的积分,做一个热心且受人欢迎的人。

 懒得打字嘛,点击右侧快捷回复【左侧自定义内容】 
您需要登录后才可以回帖 登录 | 注册账号

本版积分规则

快速回复 返回顶部 返回列表